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Missing video or screen recordings

Video / Screen Recordings Aren't Captured

Updated over a week ago

Possible Causes

  1. Disabled Screen Monitoring: The Screen Recording channel may be turned off in the global Monitoring Profile or on the specific employee's profile.

  2. Rule-Based Recording Only: If the Record only when behavior rule was violate option is enabled, the system will only capture video during specific rule incidents, leaving gaps during normal activity.

  3. Event-Only Updates: The "Update screen on events only" setting may be enabled, which stops recording during periods of total user inactivity (no mouse or keyboard input).

  4. Locked Session Settings: If "Record locked sessions" is turned off, recording stops immediately when a user locks their computer, activates a screensaver, or minimizes an RDP window.

  5. Screen Recordings Deleted:

    • Retention Policy Deletion: In On-Premises deployments, recordings may have been automatically deleted if they are older than the timeframe specified in the "Delete history after (days)" setting.

    • You have manually deleted the screen recordings by using the add/remove time option from the Employee Details screen or the Live View > Snapshot dashboard (Note: there is no solution for this as the recordings are permanently deleted).

  6. Missing macOS Permissions: On Mac computers, recordings will fail if Accessibility / Screen Recording permissions are not enabled in the macOS System Settings.

Solutions

Most of these issues can be addressed by adjusting the Screen Recording monitoring settings:

  1. Enable Screen Recording from the Configurations > Monitoring Profiles. Also, check if the employee has a Custom Profile overriding these settings by viewing the Employees screen and checking the Monitoring tab.

  2. Ensure the Record only when behavior rule was violated option is disabled in the Screen Recording monitoring settings to ensure continuous capture.

  3. Disable the Update screen on events only option in the Screen Recording monitoring settings if you want to capture video even when the user is idle.

  4. Enable the Record locked sessions option in the Screen Recording monitoring settings to maintain visibility when the computer is locked or in sleep mode.

  5. If you For On-Premises users, check Delete history after (days) in the Screen Recording monitoring settings. Adjust the days for a longer retention period or set it to 0 if you wish to disable automatic deletion (subject to disk space). If you manually deleted the recordings, unfortunately there is no way to bring them back.

  6. If you are using the Reconstructed Video, ensure the Accessibility permission is enabled. Also ensure that the Viewing in reconstructed mode is enabled in the Screen Recording monitoring settings. If you are using the Standard Video, ensure both the Accessibility and Screen Recording permissions are enabled. Check out this article to learn how to enable macOS permissions.

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