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Mac: Video / screen recordings aren't captured

Updated over a week ago

Symptoms

  • The Live View or History View in the Session Player shows a black screen or "No record available" message.

  • The Snapshots dashboard displays empty thumbnails with timestamps but no images.

  • Dashboards show a "No preview available" message for past timeslots.

  • A "Your screen is being observed" notification appears on the Mac, yet no video is visible to the administrator.

Causes

1. Missing macOS Permissions: The Teramind Agent lacks the necessary Screen Recording and Accessibility permissions required by macOS security settings.

2. Monitoring Settings Configuration: Screen recording is explicitly disabled in the user's assigned Monitoring Profile.

3. Power State Restrictions: The Mac is in sleep mode or locked, and the Record locked session setting is disabled.

Solutions

1. Grant macOS System Permissions:

Check out this article to learn how to enable the permissions.

2. Verify Monitoring Profile Settings:

Ensure Screen Recording channel is enabled under Configurations > Monitoring Profiles. If the employee is under a Custom Profile, ensure that Screen Recording is enabled in their profile's Monitoring tab.

3. Enable Locked Session Recording:

In the Screen Recording settings of your Monitoring Profile, turn ON the Record locked sessions option.

Alternative Option: Reconstructed Video

If Screen Recording permission cannot be obtained (e.g., due to user privacy restrictions), and you are using Mac Agent 26.1 or higher, then enable the Viewing in reconstructed mode option in the Screen Recoding monitoring settings. This will allow you to view the Reconstructed Video in the Session Player without requiring explicit screen recording consent.

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