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Video / screen recordings aren't captured

Updated over 3 weeks ago

Possible Causes

1. Screen recording is disabled or incorrectly configured in the Monitoring Profile.

2. The user's specific profile has custom or restrictive monitoring settings.

Solution

1. Check Screen Recording Settings in the Monitoring Profile

1. From the main menu, navigate to Configurations > Monitoring Profiles.

2. Select the relevant monitoring profile.

3. If Screen Recording isn't enable, click the Toggle button to turn it on.

4. To check further, click the Edit icon next to Screen Recording. This will open the settings panel:

5. Check the following options:

  • Record only when behavior rule was violated option. If it's enabled, Teramind will only record the screen when any active rule has the Record option set. If you want continuous recording, you should disable this option.

  • If you are on an On-Premises/Private Cloud deployment, check if the Delete history after option has the right duration set. If needed, in crease the retention period.

  • If disabled, Record locked sessions and if enabled, Update screen on events only options can create gaps in the video too.

6. Examine the following settings for potential issues:

  • If the Record only when behavior rule was violated option is enabled, Teramind will only record the screen when a behavior rule with the 'Record' action is triggered. For continuous recording, this option should be disabled.

  • If recordings are removed too quickly, increase the retention period in the Delete history after field.

  • Disabling 'Record locked sessions' or enabling Update screen on events only can both lead to gaps or incomplete video recordings. Adjust these as needed to ensure complete footage.

2. Check Screen Recording Settings in the Employee Profile

Make sure the user doesn't have a custom monitoring settings to override their Monitoring Profile. For example, a user might be part of a "Marketing" profile where they have the Screen Recording enabled. However, in their employee profile, Screen Recording is turned off. In this case, the user's custom profile will have priority and screen recording will not take place for the user.

To check a user's monitoring status, do the following:

1. From the main menu, select Employees.

2. Select the employee from the list.

3. Click the Edit Profile button.

4. Navigate to the Monitoring tab:

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5. Ensure the Screen Recording option is enabled. You can also click the Edit button to check additional options as mentioned in the previous section (Step 6).

For more information about monitoring settings, check out the Monitoring Profiles section in the Teramind User Guide.

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